Author Topic: HDBits logon problem.  (Read 4815 times)

Offline CuF

  • Sr. Member
  • ****
  • Posts: 330
  • Karma: +40/-0
    • View Profile
HDBits logon problem.
« on: January 12, 2013, 03:49:41 am »
Trying a standard login fails.  I believe it's because there is a unique code generated each time you go to the login page that must be passed with the name/pass.
Code: [Select]
<input type="hidden" name="lol" value="9ef07eb08afd6ce379e755716c9919bc" />The value changes every time you refresh the page.

I tried special login by adding 'special=1' in the [script] section, but when BC tries a search it only loads the login page, not the search page.

Is there any reason the special login might fail?

Offline chip!

  • Bad Ass
  • Administrator
  • Unstoppable
  • *****
  • Posts: 2301
  • Karma: +629/-6
    • View Profile
Re: HDBits logon problem.
« Reply #1 on: January 12, 2013, 05:19:50 am »
Can't think of why special would fail.. maybe just a script config issue. I will take a look at this later but I might also add some additional functionality to the prelogin cookie fetch option and then maybe let the regular login handle it. Will have to play around with it.
  -  https://convivea.com  -   And...  boom goes the dynamite.

Offline CuF

  • Sr. Member
  • ****
  • Posts: 330
  • Karma: +40/-0
    • View Profile
Re: HDBits logon problem.
« Reply #2 on: January 12, 2013, 05:55:25 am »
I also update the rutracker.org script.  Had trouble getting it to log in.

Finally it did (not sure what I changed that made a difference).  Did a few searches and then it stopped logging in properly again.

I tried going by way of special=1 just to fix a bug in the search for now and that still fails.

Both of these, even when set to special login, a search will only retrieve the login page.  Maybe something changed and I'm doing it wrong.

Is it just this to use special login?

Code: [Select]
[script]
name=rutracker.org
source=rutracker
author=CuF
modified=2013/01/11 by CuF
version=2
pwd=1

[home]
1=http://rutracker.org

[profiles]
all=/forum/tracker.php?nm=%SEARCH%

[login]
login=http://login.rutracker.org/forum/login.php

Offline chip!

  • Bad Ass
  • Administrator
  • Unstoppable
  • *****
  • Posts: 2301
  • Karma: +629/-6
    • View Profile
Re: HDBits logon problem.
« Reply #3 on: January 15, 2013, 02:18:25 pm »
I also update the rutracker.org script.  Had trouble getting it to log in.

Finally it did (not sure what I changed that made a difference).  Did a few searches and then it stopped logging in properly again.

I tried going by way of special=1 just to fix a bug in the search for now and that still fails.

Both of these, even when set to special login, a search will only retrieve the login page.  Maybe something changed and I'm doing it wrong.

Is it just this to use special login?

Code: [Select]
[script]
name=rutracker.org
source=rutracker
author=CuF
modified=2013/01/11 by CuF
version=2
pwd=1

[home]
1=http://rutracker.org

[profiles]
all=/forum/tracker.php?nm=%SEARCH%

[login]
login=http://login.rutracker.org/forum/login.php



maybe those sites had cookies with "|" in it... which would cause BC to fail once it translated the item from the ListView over to the results, and then sent malformed cookies to the downloader.. which then seems to break the download for some sites :(  argggg... major pain but i've fixed it and will be releasing it soon.....  unless I get the opportunity to try and fix that redirect bug you may have found.

thanks
chip
  -  https://convivea.com  -   And...  boom goes the dynamite.